Galactic Civilization

Create account
Login
Downloads
NewsGroup
Community
Purchase
Galactic Forum
Strategies
Mods
Empires
Do you still think GalCiv 1 is fun even with GalCiv II out?
758 votes
1- Yes
2- No


Galactic Civilization Map Editor and campaign Crash
  Search:   
Go to Bottom         Go to Bottom
by Citizen Troy Ronholdt - 3/28/2005 10:21:37 PM

I bought the Deluxe edition of the game at the local store. I was interested in the map editor, but it crashes every time I start it. Checked the Dxdiag and it's all good dx9. I also moved the files off to their own folder as seen in another post. The game itself always crashes when trying to run a campaign. Downloaded the lastest updates from stardock, but that did not help. My email to product support went unanswered.

Last attempt to try and save this game. Let me know what information would be helpful to resolve this.

Appreciate anyones help in advance.

AMD/Radeon 8500/and XP home. Latest drivers are installed.

      
#1  by Citizen ForesterGC - 3/29/2005 2:22:36 PM

It sound like the Video Card is causing the CTD.

You said you have dx9 but is the video card driver updated or is the card even supported.



             Posted via Stardock Central
#2  by Citizen Troy Ronholdt - 3/29/2005 3:03:08 PM

I did get a response from support. I have some data to collect for them as their recommendations didn't work for me. I tried updating the Vid drivers. Didn't help. I also ripped the game and reinstalled. That didn't help either. Oh well, I'll keep trying

      
#3  by Citizen Troy Ronholdt - 4/4/2005 11:42:31 AM

I seem to have exhausted Product support on this. They just pointed me to this forum. Anyone have ideas on data I could collect to help debug this?

      
#4  by Citizen ForesterGC - 4/4/2005 1:48:44 PM

A bug one game had that I betaed was tht the video had to be 1024 till they fixed it.

The only thing I could think of now is to play with any video/monito setting.

            
#5  by Citizen Chippoka - 4/8/2005 4:31:38 PM

I had the same problem. I eventually tried changing the screen resolution to a higher setting: 16 color, 1152x864, in order to see all the map buttons... it also needs be large so that the large size maps will display without crashing (perhaps).... that's just a guess on my part. But it works fine for me now. It's tricky to use, and may crash due to some bugs it seems to have when putting in out-of-range values or manipulating elements wrongly with the mouse. Hope it works for you!



      
<<   (1)   >> 
   Page 1 of 1   

Go to Top    Go Back to Message Board    Go to Top
To be able to post something you have to become a member
Click here!



Copyright 1995-2020 Stardock Corporation. All rights reservered.
Site created by Pixtudio and Stardock, designed by Pixtudio.