Galactic Civilization

Create account
Login
Downloads
NewsGroup
Community
Purchase
Galactic Forum
Strategies
Mods
Empires
Do you still think GalCiv 1 is fun even with GalCiv II out?
758 votes
1- Yes
2- No


Fresh install of GalCiv + AP from SDCentral freezes...
  Search:   
Go to Bottom         Go to Bottom
by Citizen Dekzar - 10/30/2005 1:42:18 PM

Hi there,

I've been playing Galactic Civilizations for a while, and I just bought a new computer. When I first installed GC + AP (Deluxe Edition), I tried running it, and it got to the menu, I set up a game, and started it. The game loaded, and got to the Galaxy Map, with that popup window that shows up every time you start the game, about the hyperdrive and such. But from there it just freezes. No sound, can't click anything, I have to use the task manager to kill the process.

So I figure, maybe the newest version will help. I uninstalled the game + expansion, and then reinstalled them fresh from Stardock Central (Downloaded and everything. There's nothing from my Deluxe Edition installed, it's all the latest version.), but I still get the game problem.

Any ideas how to fix this?

System:

AMD Athlon 64 X2 4400+
2 GB Mushkin memory
XFX nVidia 7800GTX (Factory overclocked to 490 mhz)

I think it may be the dual core processor giving it trouble, though I really don't know. But I do know the game works fine on my older PC (A single-core Athlon XP), and my ancient laptop (900 mhz Pentium 3).

So...any ideas?

      
#1  by Citizen Walldorf2000 - 10/31/2005 3:55:53 AM

In similar cases a new driver for your sound chip did help.

When it does not help you should install SmartException and let it run in parallel. This should help Stardock to identify your problem.

                              
<<   (1)   >> 
   Page 1 of 1   

Go to Top    Go Back to Message Board    Go to Top
To be able to post something you have to become a member
Click here!



Copyright 1995-2020 Stardock Corporation. All rights reservered.
Site created by Pixtudio and Stardock, designed by Pixtudio.