Galactic Civilization

Create account
Login
Downloads
NewsGroup
Community
Purchase
Galactic Forum
Strategies
Mods
Empires
Do you still think GalCiv 1 is fun even with GalCiv II out?
758 votes
1- Yes
2- No


GalCiv AP 1.52b Crashes
  Search:   
Go to Bottom         Go to Bottom
by Citizen Ivan Maclaine - 12/11/2005 8:50:08 PM

I've been having some crash problems with AP, which on a recent game, have stopped me completely. Up until recently, AP would crash every couple of hours or so, generally in the Diplomacy screens, and I could simply load an auto-save, and keep going.

Now, though, I'm well progressed in a game, and after the crash, both my most recent and previous auto-saves both cause a crash when loading. I can load other save games, but my only other from this game is so old to not be worthwhile.

I've tried reinstalling GalCiv and AP (1.52b), as well as Codecs and Bink. The link that I've seen for codecs on this forum actually gave an error (The file ..\L3codeca.acm could not be opened), so I downloaded an ACE codec pack, which seems to include all the Media Player codecs, amongst others).

Below is the last few lines from my debug.err file:

Debug Message: No data definition files at path Mods\Data\UP_Issues\*.UPISSUE
Debug Message: No data definition files at path Mods\Data\*.RESOURCE
Debug Message: No data definition files at path Mods\Data\InvasionTactics\*.INVTACTIC
Debug Message: No data definition files at path C:\Program Files\Stardock\TotalGaming\galciv\Mods\Data\*.SBMODULE
Debug Message: No data definition files at path Mods\Data\*.SBMODULE
Debug Message: Loading game.
Debug Message: Could not find animation titled Default in model 4Decoration (PlayAnimation)

And here is the info from the .cra file from SmartException:

Stardock SmartException Logging Information
-------------------------------------------

OS Version : Windows 2000
Video Card : ATI MOBILITY RADEON 7500
Application Exception code: C0000005 ACCESS_VIOLATION
Crash Addr: 004CB381 01:000CA381 C:\Program Files\Stardock\TotalGaming\AltarianProphecy\GalCiv.exe

Processor Registers (x86):
EAX:00000001
EBX:00000026
ECX:0012F364
EDX:00002400
ESI:08D3F288
EDI:00000000
CS:EIP:001B:004CB381
SS:ESP:0023:0012F380 EBP:08D3F524
DS:0023 ES:0023 FS:003B GS:0000
Flags:00010202


Current Application Call Stack:

Addr Frame Logical addr Module Name
---------------------------------------------
004CB381 08D3F524 0001:000CA381 C:\Program Files\Stardock\TotalGaming\AltarianProphecy\GalCiv.exe


Debug information for each stardock app follows ....


If anyone has any tips or ideas, they'd be greatly appreciated, as I'm now a bit reluctant to start a new game in case the same thing eventually happens again.

Many thanks,

Ivan.

                
#1  by Citizen Cetane - 12/23/2005 7:13:14 PM

Edit: Wrong e-mail.
[Message Edited]

                            
#2  by Citizen Cetane - 12/23/2005 7:13:29 PM

Have you tried support@stardock.com Email

                            
#3  by Citizen Ivan Maclaine - 1/6/2006 2:04:10 AM

I've just tried that, and they replied with the suggestion to uninstall and reinstall. Well, I had tried that, but tried it again anyway, and guess what? It now works!

For anyone that has a similar problem and comes across this thread, my exact procedure was:

1. Reboot
2. Uninstall Altarian Prophecy
3. Delete all other Altarian Prophecy folders and files other than data/savegames
3. Reboot
4. Reinstall Altarian Prophecy
5. Reboot

Maybe the extra reboots helped...

Anyway, thanks for the email address advice!

                
<<   (1)   >> 
   Page 1 of 1   

Go to Top    Go Back to Message Board    Go to Top
To be able to post something you have to become a member
Click here!



Copyright 1995-2020 Stardock Corporation. All rights reservered.
Site created by Pixtudio and Stardock, designed by Pixtudio.