Galactic Civilization

Create account
Login
Downloads
NewsGroup
Community
Purchase
Galactic Forum
Strategies
Mods
Empires
Do you still think GalCiv 1 is fun even with GalCiv II out?
758 votes
1- Yes
2- No


Vista 64
  Search:   
Go to Bottom         Go to Bottom
by Citizen wtlgditc - 9/22/2007 2:30:01 AM

I'm guessing I'm the only one with this problem and that there will be no fix... none the less, I have to ask. I have Altarian Prophecy and it installed just fine on Vista x64, but it won't run, crashing with GCloader errors. The original Galactic Civilization works seemingly fine - I haven't actually gone into the game mode of ACTUAL play, but it gets through the intro fine.

Any suggestions? I've tried running it under the various app compatibility settings and with admin rights, but still no luck.

          
#1  by Citizen marriageishell - 3/21/2008 8:15:25 PM

I have the same problem it keeps crashing on startup. my galactic civilization 1 also does this after a few seconds of starting If you find the cure for this please email me at marriageishell@aol.com Email thanks

                    
#2  by Citizen Nubbuchadnezzar - 9/17/2008 3:38:37 PM

For Galactic Civilizations 1, to the folder containing the game, and try running GalCiv.exe.

When I tried using gcloader, it kept crashing, but running the game directly worked fine for me.

      
#3  by Citizen Tregonsee - 3/23/2009 8:17:03 AM

I ultimately made my new laptop a dual boot (vista/xp), but then the vista worked fine with GC1. I think I fiddled with vista controls.

                      
<<   (1)   >> 
   Page 1 of 1   

Go to Top    Go Back to Message Board    Go to Top
To be able to post something you have to become a member
Click here!



Copyright 1995-2020 Stardock Corporation. All rights reservered.
Site created by Pixtudio and Stardock, designed by Pixtudio.