Galactic Civilization

Create account
Login
Downloads
NewsGroup
Community
Purchase
Galactic Forum
Strategies
Mods
Empires
Do you still think GalCiv 1 is fun even with GalCiv II out?
758 votes
1- Yes
2- No


GalCiv doesn't work on Vista
  Search:   
Go to Bottom         Go to Bottom
by Citizen Mrylanxus - 11/20/2008 11:51:52 PM

Just installed GalCiv from a jewel case CD. However, when I try to start the program, Vista popups the following message:

gcloader.exe has stopped working

How can it stop working if it never starts?

rmfr

#1  by Citizen The Beastmaster - 1/3/2009 8:27:37 PM

I only played GalCiv on Win XP.
Haven't installed it to vista yet...
Has anyone been able to run GalCiv I on Vista?

                
#2  by Citizen Will726 - 8/10/2009 9:48:17 PM

I just installed it, but I haven't tried running it yet. I'll edit in the results after I try starting it.

EDIT: It works fine for me, it runs about 5x as fast as it did on my win98.
[Message Edited]

#3  by Citizen Dragonshrike - 8/12/2009 10:48:18 AM

I've had it on Vista since I started and have no troubles. I've never done anything exotic like add mods though; just the basic game. It sometimes runs slow when showing AI battles but a CTRL ALT DEL and cancel helps bypass that.

                            
#4  by Citizen ElliotTaylor489 - 8/21/2009 1:53:30 PM

I have tried it on every version of Windows (inncluding dos!) and it works fine on all of them.
Not tried it on Windows 7 yet though...

#5  by Citizen The Beastmaster - 10/27/2011 11:52:22 PM

Came back to play my Gal Civ I Ultimate Edition on my Vista CPU now... and it pretty near locks up with every ship battle.

You can work your way out of the ship battle stall=lockup with clicking the windows key (and then clicking on the task bar to come back into the game) or do the CTRL ALT DEL as Dragonshrike listed, BUT... each ship fight takes about 20 seconds to complete doing it this way (it seems like much longer). Not very practical for play purposes if you play to win via conquest in your games. It's very frustrating.

                
#6  by Citizen The Beastmaster - 10/27/2011 11:54:18 PM

And yes, I've tried adjusting the game with all the Vista "compatability" options... they don't help.

If anyone knows a fix, please post it here. Thanks in advance.

                
#7  by Citizen The Beastmaster - 10/28/2011 1:07:37 AM

And yes... I know I can turn ship battles off in the Options menu, but to me, watching the ships fight is a very fun part of the game.

                
#8  by Citizen The Beastmaster - 11/1/2011 12:00:43 PM

Using VISTA, I finished a game, no lock ups or slow downs with these 2 options turned to off, SHOW HUMAN SHIP BATTLES, SHOW AI SHIP BATTLES.
I added this in case anyone is still playing this game with VISTA, it does work well, with those 2 options turned to OFF.

                
<<   (1)   >> 
   Page 1 of 1   

Go to Top    Go Back to Message Board    Go to Top
To be able to post something you have to become a member
Click here!



Copyright 1995-2017 Stardock Corporation. All rights reservered.
Site created by Pixtudio and Stardock, designed by Pixtudio.