Galactic Civilization

Create account
Galactic Forum
Do you still think GalCiv 1 is fun even with GalCiv II out?
758 votes
1- Yes
2- No

Windows 7 Compatibility
Go to Bottom         Go to Bottom
by Citizen EDupuis - 1/14/2010 3:10:41 AM

I've installed onto a new PC that uses Windows 7. The program locks when combat starts. Any suggestions on fixing this?

#1  by Citizen thrasymedes - 9/2/2010 12:10:18 AM

It's not really a solution, but I've found that if I press the "windows" key, the combat gets resolved as I go out to the desktop, then when I click on the game in the taskbar I'm able to play it again. Yeah, a horrible clumsy workaround, but it is technically possible to play. A real solution would be great, though.

#2  by Citizen prepod - 9/21/2010 7:19:23 AM

[Message Edited]

#3  by Citizen prepod - 9/21/2010 7:20:38 AM

I don't know would my suggestion be helpful, but I have resolved described problem this way:
1. I've downloaded and installed the following update 1.20 Link
2. I've do the following:
a) put a galciv.exe file(not a gcmenu) to the desktop of my Windows 7 as a shortcut;
b) select it with the right mouse button and choose "Settings" then "Compatibility" tab
c) there should be chosen a "Windows 98/Windows ME" compatibility and the mark of administrator rights should be set, press "Apply" then "OK"
3. Run the game with this freshly generated shortcut and start a scenario then go to "Options" and set "Show player battles" and "Show AI battles" to OFF

It works fine for me on Windows 7 x32 bit and there is no issues described above.
I play not an Altarian Prophecy, but an Expanded Universe expansion.

PS Sorry for my english
[Message Edited]

<<   (1)   >> 
   Page 1 of 1   

Go to Top    Go Back to Message Board    Go to Top
To be able to post something you have to become a member
Click here!

Copyright 1995-2023 Stardock Corporation. All rights reservered.
Site created by Pixtudio and Stardock, designed by Pixtudio.