Galactic Civilization

Create account
Login
Downloads
NewsGroup
Community
Purchase
Galactic Forum
Strategies
Mods
Empires
Do you still think GalCiv 1 is fun even with GalCiv II out?
758 votes
1- Yes
2- No


1.02Z (beta) Bug Thread
  Search:   
Go to Bottom         Go to Bottom
by Citizen Jazzlvr - 4/22/2003 8:05:54 PM

1. You can't use ctrl-n to recreate the map; it crashes to the desktop: repeatable.

2. Once you've installed the beta, you can't get back to the original political party choices without a complete delete and reinstall. Even a simple uninstall and reinstall will leave the choices as the first several (before the box scrolls) political parties from the beta: repeatable. This one's annoying because I'd installed all the mods from the library (long time) and now I've got to do it all over again...

       
#1  by Citizen Jazzlvr - 4/22/2003 8:15:00 PM

#2 above seems to be related to bigshot3754's Party Pack from the Library; experiments continue.

       
#2  by Veteran RationalCop - 4/22/2003 8:20:26 PM

Still had an instance of dual transport production at the beginning of the game.



        Posted via Stardock Central
#3  by Citizen JavaCodeToad - 4/22/2003 8:46:40 PM

CTD at first election.

debug.err
Debug Message: AIAltarian: Set Colony Social
Debug Message: Preparing to save game.
Debug Message: Deleting previous save game.
Debug Message: No Data\SaveGames\AutoSave\*.* files in current directory.
Debug Message: Save Game.
Debug Message: Unable to open file gfx/PolPartyLogos/Populists_Large.pcx
ASSERT ERROR in file G:\PROJECTS\pear\SOURCE\DISKDATA.CPP at line 119.
Debug Message: Unable to open Bitmap file: gfx/PolPartyLogos/Populists_Large.pcx
Debug Message: Unable to open file gfx/PolPartyLogos/Populists_Large.pcx
ASSERT ERROR in file G:\PROJECTS\pear\SOURCE\DISKDATA.CPP at line 119.
Debug Message: Unable to open Bitmap file: gfx/PolPartyLogos/Populists_Large.pcx
Debug Message: Unable to open file gfx/PolPartyLogos/Federalists_Small.pcx
ASSERT ERROR in file G:\PROJECTS\pear\SOURCE\DISKDATA.CPP at line 119.
Debug Message: Unable to open Bitmap file: gfx/PolPartyLogos/Federalists_Small.pcx
Debug Message: Unable to open file gfx/PolPartyLogos/Populists_Small.pcx
ASSERT ERROR in file G:\PROJECTS\pear\SOURCE\DISKDATA.CPP at line 119.
Debug Message: Unable to open Bitmap file: gfx/PolPartyLogos/Populists_Small.pcx
Debug Message: Unable to open file gfx/PolPartyLogos/WarParty_Small.pcx
ASSERT ERROR in file G:\PROJECTS\pear\SOURCE\DISKDATA.CPP at line 119.
Debug Message: Unable to open Bitmap file: gfx/PolPartyLogos/WarParty_Small.pcx
Debug Message: Unable to open file gfx/PolPartyLogos/Pacifists_Small.pcx
ASSERT ERROR in file G:\PROJECTS\pear\SOURCE\DISKDATA.CPP at line 119.
Debug Message: Unable to open Bitmap file: gfx/PolPartyLogos/Pacifists_Small.pcx
Debug Message: Unable to open file gfx/PolPartyLogos/Technologists_Small.pcx
ASSERT ERROR in file G:\PROJECTS\pear\SOURCE\DISKDATA.CPP at line 119.
Debug Message: Unable to open Bitmap file: gfx/PolPartyLogos/Technologists_Small.pcx
Debug Message: Unable to open file gfx/PolPartyLogos/Mercantile_Small.pcx
ASSERT ERROR in file G:\PROJECTS\pear\SOURCE\DISKDATA.CPP at line 119.
Debug Message: Unable to open Bitmap file: gfx/PolPartyLogos/Mercantile_Small.pcx
Debug Message: Unable to open file gfx/PolPartyLogos/Misc04_Small.pcx
ASSERT ERROR in file G:\PROJECTS\pear\SOURCE\DISKDATA.CPP at line 119.
Debug Message: Unable to open Bitmap file: gfx/PolPartyLogos/Misc04_Small.pcx
Debug Message: Unable to open file gfx/PolPartyLogos/Misc01_Small.pcx
ASSERT ERROR in file G:\PROJECTS\pear\SOURCE\DISKDATA.CPP at line 119.
Debug Message: Unable to open Bitmap file: gfx/PolPartyLogos/Misc01_Small.pcx




                   Posted via Stardock Central
#4  by Avatar Frogboy - 4/22/2003 9:04:49 PM

Interesting.
I'll double check on that. I may have missed a file being uploaded. There were a LOT of chnages made to the election stuff.

                      
#5  by Citizen Jazzlvr - 4/22/2003 9:29:54 PM

CTD on ctrl-n right after start of game:

Stardock SmartException Logging Information
-------------------------------------------

OS Version : Windows XP
Video Card : NVIDIA GeForce4 Ti 4400
Application Exception code: C0000005 ACCESS_VIOLATION
Crash Addr: 00407560 01:00006560 C:\Program Files\Galactic Civilizations\galciv.exe

Processor Registers (x86):
EAX:00000001
EBX:00000000
ECX:00000000
EDX:00000002
ESI:000050F4
EDI:0012C784
CS:EIP:001B:00407560
SS:ESP:0023:0012BA08 EBP:0012BA0C
DS:0023 ES:0023 FS:003B GS:0000
Flags:00010202


Current Application Call Stack:

Addr Frame Logical addr Module Name
---------------------------------------------
00407560 0012BA0C 0001:00006560 C:\Program Files\Galactic Civilizations\galciv.exe
0051D2F7 0012BA1C 0001:0011C2F7 C:\Program Files\Galactic Civilizations\galciv.exe
004F649E 0012E5FC 0001:000F549E C:\Program Files\Galactic Civilizations\galciv.exe
004FFA4C 0012FA94 0001:000FEA4C C:\Program Files\Galactic Civilizations\galciv.exe
00526B88 0012FC2C 0001:00125B88 C:\Program Files\Galactic Civilizations\galciv.exe
0051006F 0012FCC4 0001:0010F06F C:\Program Files\Galactic Civilizations\galciv.exe
00570604 0012FCF8 0001:0016F604 C:\Program Files\Galactic Civilizations\galciv.exe
77D67AD7 0012FD24 0001:00026AD7 C:\WINDOWS\system32\USER32.dll
77D6CCD4 0012FD8C 0001:0002BCD4 C:\WINDOWS\system32\USER32.dll
77D45CD6 0012FDBC 0001:00004CD6 C:\WINDOWS\system32\USER32.dll
77D45CF5 0012FDDC 0001:00004CF5 C:\WINDOWS\system32\USER32.dll
5101EA58 0012FE08 0001:0001DA58 C:\WINDOWS\System32\DDRAW.dll
77D67AD7 0012FE34 0001:00026AD7 C:\WINDOWS\system32\USER32.dll
77D6CCD4 0012FE9C 0001:0002BCD4 C:\WINDOWS\system32\USER32.dll
77D44455 0012FEFC 0001:00003455 C:\WINDOWS\system32\USER32.dll
77D44D58 0012FF34 0001:00003D58 C:\WINDOWS\system32\USER32.dll
005AA82A 0012FFC0 0001:001A982A C:\Program Files\Galactic Civilizations\galciv.exe
77E814C7 0012FFF0 0001:000204C7 C:\WINDOWS\system32\kernel32.dll


Debug information for each stardock app follows ....

       
#6  by Citizen JavaCodeToad - 4/22/2003 9:32:43 PM

Frogboy

I do not have the gfx/PolPartyLogos directory of any of the files on my hard drive.

JavaCodeToad



                   Posted via Stardock Central
#7  by Citizen Jazzlvr - 4/22/2003 9:37:34 PM

You can get the same SmartException readout as above if you start a new game, then select "Menu", then "Main Menu", then "Start New Civilization", then "Next", then "Done"...the game will CTD while setting up the new game: repeatable.

       
#8  by Avatar Frogboy - 4/22/2003 9:40:35 PM

Great reports guys! Thanks a ton!

                      
#9  by Avatar Frogboy - 4/22/2003 10:07:56 PM

Okay, new build now up.

There were a bunch of PCX files that were missing that I wasn't aware of. The good news is, you can now create your own logos for your political party (Beore they were hard coded). So if you want to create the Democrats or Republicans or Liberal party or whatever, you can make a logo for them.

I just tested it and the Ctrl-N and the crash on election shoudl be taken care of by this (it was here on my home laptop anyway). It's 1.02Z.004 just so that' were on the same page.





                       Posted via Stardock Central
#10  by Citizen Robert Viener - 4/22/2003 10:37:09 PM

Getting error trying to download .004b have .003b
Bob

       
#11  by Citizen Robert Viener - 4/22/2003 10:51:00 PM

Got the download. Problem was probably server overload. Bob

       
#12  by Citizen Bazuul - 4/23/2003 12:12:25 AM

Can't use mousewheel to scroll economic sliders on economy screen. Mousewheel scrolls faction list instead.



          Posted via Stardock Central
#13  by Citizen dikdirk - 4/23/2003 10:17:06 AM

Does mousewheel already work with starbase modules?

#14  by Citizen Starjammer - 4/23/2003 12:51:30 PM

Right about now I am wondering why I keep experiencing crashes during the game. This happened with the 1st patch and bonus pak and now is still happening with the new 1.02 version, (which by the way, I am appreciative for) but the game experience is nullified when I can't play it for more than twenty minutes before experiencing a crash to the desktop. I have DirectX9, I have the latest SoundBlaster drivers, 1 gig of RAM, ... don't know what else to do... Anyone have any advice?

Starjammer

#15  by Diplomat Ralegh - 4/27/2003 8:14:32 PM

Yeah. Turn off autosave. (Your mileage may vary, but this completely removed the regular crashes I was having...) - Just remember to save occasionally!



                       Posted via Stardock Central
#16  by Citizen Zeitgeis - 4/8/2005 3:04:29 PM

The first two or so screens vibrate horizontally pretty wildly -- through selection of enemy screens.



       Posted via Stardock Central
<<   (1)   >> 
   Page 1 of 1   

Go to Top    Go Back to Message Board    Go to Top
To be able to post something you have to become a member
Click here!



Copyright 1995-2021 Stardock Corporation. All rights reservered.
Site created by Pixtudio and Stardock, designed by Pixtudio.