Galactic Civilization

Create account
Login
Downloads
NewsGroup
Community
Purchase
Galactic Forum
Strategies
Mods
Empires
Do you still think GalCiv 1 is fun even with GalCiv II out?
758 votes
1- Yes
2- No


Sound Problems/Frequent Crashes Troubleshooting
  Search:   
Go to Bottom         Go to Bottom
by Senator CariElf - 6/24/2004 1:16:16 PM

We have not changed the sound or music code for several versions of Gal Civ.  I don't know why, but people sometimes suddenly start having problems with the sound after they upgrade to a new version. 

The latest update to Gal Civ multimedia contains resampled mp3s to the format that our mp3 player likes the best, so this should cut down a lot of problems that people have with the sound.

About 90% of problems with frequent crashes are due to problems with your sound codecs or drivers and our mp3 player not playing nice.

Here are some things that you can try to get your sound working again:

1) Update your sound drivers if there is a newer version.  Re-install if you don't have a newer version.

2) If you don't have the latest version of DirectX installed, update it.  Also run dxdiag and do all the sound tests to make sure that there are no problems.

3) http://www.stardock.com/files/ms_mp3codec.exe - this link will re-install Microsoft's default system codecs.  Sometimes other programs install their own buggy versions of these codecs and overwrite them.

4) Run Windows update.  I'm pretty sure that there's an update that addresses static in games.

5) http://www.radgametools.com/bnkdown.htm - this is a link to the download page for the bink tools.  If another program like QuickTime has taken over your bink associations, that could cause problems with the sound. Installing the bink tools should reclaim the associations.

6) As I mentioned in #3, some programs install buggy mp3 codecs.  These can also cause crashes.  Windows Media Player is always safe.  WinDVD and Winamp3 are known to have buggy codecs.  Updating to newer versions of these programs may help if they've fixed their codecs.  You probably don't need to try un-installing these programs unless you are getting frequent crashes as well as the static. 

We have a program called SmartException under the Free Stuff tab in Stardock Central that will often catch the file that is causing the crash and report it in a file named GalCiv.exe.cra

 

7) Make sure that the mp3s play in another media player without the static.  If you're still getting static, you may need to re-install the multimedia.

8) Try starting Gal Civ with a shortcut that points directly at Gal Civ, not through the GCMenu that is installed by the CD.  The flash autoplay program opens up a sound channel that it doesn't close before Gal Civ opens.

9) Intel Application Accelerator has been known to cause crashes with certain chipsets.  Updating to a newer version may solve the problem, but in some cases it must be un-installed.

carielf@stardock.com


[Message Edited]
[Message Edited]

        
#1  by Citizen H0D - 6/26/2004 6:26:37 AM

I only bought the game last week, patched it and almost immediately started suffering from similar problems. The game tends to hang my whole PC with a repeating sound (click?). I've re-installed DX9 and my soundcard drivers (Audigy2) but still get problems. The only thing that APPEARS to work, is to make sure nothing else is running. Very frustrating as I really enjoy the game. It's what I've been looking for for years!

          
#2  by Citizen Scribblette - 6/28/2004 3:10:44 AM

I've downloaded those mp3 codecs from Stardock numerous times (on ADSL, with and without Download Accelerator Plus 7), but they seem to have some sort of install error... when installing it talks about a missing file *redownloads to see error message*

"The file C:\Documents and Settings\Sam Rivers\Desktop\l3codecp.acm could not be opened."

I have no idea how to bypass that error.

My specific audio problem is that audio on occasion skips. The music, whatever - unless I'm using Winamp for movies/mp3s, or playing a bink movie directly through bink, audio skips on my PC. It's annoying when music skips like that. It's really frustrating with windows media player doing it all the time, and even programs like Reason (music composing software), rendering them rather useless >_<

Even Max Payne 2 skipped with voices on occasion. Annoying.

The only static I've experienced is when I try and play Deus Ex. Annoying. Again.

I'm using a Vibra128 in PCI slot 2 with IRQ 6 (I think), 512 RAM, Athlon XP 1800+, running WinXP.

      
#3  by Citizen Aww_Nuts - 7/2/2004 6:36:10 AM

I used Terror Stars in my last game and every time the game would crash to my Windows screen on the next turn. I saw this thread, followed all of the program/driver update procedures and it fixed my Terror Star crash problem. BTW, I'm using "Gal Civ v1.20".

Many thanks CariElf!


                      
#4  by Senator CariElf - 7/2/2004 3:10:52 PM

I was mistaken about the resampled mp3s being available.  They were only on the private server.  They will, however, be publicly available today.

        
#5  by Senator CariElf - 7/2/2004 5:09:41 PM

Multimedia update is there.

        
#6  by Senator CariElf - 7/12/2004 9:57:24 AM

Crashes can also be caused by bink files missing a few bytes off the end of the file, usually caused by some kind of problem while the files are being installed.  These are the filesizes for the Gal Civ bink files associated with the aliens, the most likely to cause what seem to be random crashes when the game tries to bring up the UP or an alien asking for a trade.

3,444,880 1_trade00.bik
3,667,600 1_trade01.bik
3,442,796 1_trade02.bik
2,968,160 2_trade00.bik
1,613,752 2_trade01.bik
1,495,952 2_trade02.bik
3,340,512 3_trade00.bik
3,345,224 3_trade01.bik
3,335,052 3_trade02.bik
2,979,484 4_trade00.bik
2,760,968 4_trade01.bik
3,003,348 4_trade02.bik
2,466,732 5_trade00.bik
3,577,556 5_trade01.bik
3,536,040 5_trade02.bik

galciv\gfx

3,720,016 UPRace01_00.bik
6,911,340 UPRace02_00.bik
3,915,776 UPRace03_00.bik
3,104,800 UPRace04_00.bik
6,815,640 UPRace05_00.bik

AltarianProphecy\movies

1,090,440 6_trade00.bik
1,090,284 6_trade01.bik
1,090,088 6_trade02.bik
1,090,280 7_trade00.bik
1,090,700 7_trade01.bik
1,090,380 7_trade02.bik



        
#7  by Citizen MaDD PaPPy - 7/16/2004 1:28:57 PM

Greetings All:

Like some others, I was still having problems with CTDs after following the recommended fixes. I couldn't get beyond the next move after my last (manual) save.

Then I considered that these only occurred when my galaxy became quite large (huge, even), and then only after the obvious slow-downs with saving. As memory allocated to video plays a part in everything, I figured I'd try to lower my color from true (32-bit) to high (16-bit). I haven't experienced a CTD since. (I'm still keeping my fingers crossed.)

Of course, if you're a 32-bit purist...



      
#8  by Citizen MaDD PaPPy - 7/16/2004 3:43:03 PM

Sorry, folks...spoke too soon.

The universe grew fairly rapidly and saved well up until the point when I had death stars floating all over the place. I declared war on the whole bloody lot, and then the game crapped out and remains in that condition.

I'm beginning to think there's a memory leak somewhere in the coding. This reminds me a aweful lot of Falcon 4 (back in the day) and the issues with their coding and its effect on the game (i.e. constant CTDs). [I don't mean any offense by that comment...only to suggest the possibility of some minor oversight.]

Be well!

      
#9  by Senator CariElf - 7/16/2004 4:20:44 PM

What version are you playing?

There may be some lingering problems caused by Terror Stars destroying stars that are part of a trade route, but the most recent version is the best. 



        
#10  by Citizen MaDD PaPPy - 7/17/2004 3:04:51 PM

...1.20

I changed my approach to reflect your comments above (re. trade routes). That helped with the CTDs (many thanks); unfortunately, now I'm dead (thanks again). !

Regards!

      
#11  by Citizen Paguma - 7/17/2004 4:13:47 PM

I went through the list to no avail so I have emailed the log from SmartException and the save game that consistently reproduces the crash on my machine on the 2nd turn.


                        
#12  by Citizen Sarcerok - 7/26/2004 4:06:17 PM

You mean this game has sounds? Lol ok I think I have more problems here than just my game crashing over and over on the same date I'm going down the list of help suggestions, so far no luck.

#13  by Citizen Lord KiRon - 7/27/2004 5:02:16 PM

After reinstalling the game (after fresh WinXP install) and updating all updates can't get any sound at all , not even music , only button clicks. But no crashes ...
Bough Altarian Prophecy , installed - same problem




           Posted via Stardock Central
#14  by Citizen 8146 - 8/25/2004 1:02:29 AM

just bought the upgrade- system crashes as it is building the universe-never had this problem with the original game- please help


thanks
markgrod@aol.com Email

#15  by Senator CariElf - 8/25/2004 9:20:18 AM

Sarcerok and Lord KiRon, not sure how I missed replying to your posts.  If either of you read this, please send me your debug.err file and a dxdiag report.

8146, you have mail from me requesting a debug.err file and other information.

My e-mail is carielf@stardock.com



        
#16  by Citizen moss_icon - 8/26/2004 1:43:46 AM

i can't even get the game to start since getting the upgrade. i start galciv, the screen goes black and my HD churns away, then it dumps me to desktop. should i send these files too? hope you can help!! thanks!



           Posted via Stardock Central
#17  by Senator CariElf - 8/26/2004 10:11:42 AM

moss icon:

1) Did you install Altarian Prophecy to its own directory? If you overwrote the GalCiv directory, you'll definitely get crashes.

2) Have you updated Gal Civ to 1.21?

If the answer to both of these is yes, e-mail me your debug.err file and a dxdiag report. Also please make sure that you either reference this link or sufficiently identify yourself and your problem so that I know what I'm talking about. That way, I won't have to e-mail you and ask you who you are and what you need.


[Message Edited]

        
#18  by Citizen moss_icon - 8/26/2004 12:37:52 PM

ack, i installed it to the Galciv directory as when i initially attempted to install it to a seperate directory, the install failed, and i guessed it was because i had tried it in a different one. stupid me. i guess i have to completely reinstall everything then? sorry!!



           Posted via Stardock Central
#19  by Senator CariElf - 8/27/2004 8:59:30 AM

moss icon: don't worry, you're not the only one

        
#20  by Citizen andersonchew - 9/1/2004 12:10:54 PM

its always hanged during the games!!! anyone can help



       Posted via Stardock Central
#21  by Senator CariElf - 9/2/2004 11:08:23 AM

1) Please don't spam this thread or any others.

2) I'm going to need more info than that.  Have you followed all the directions in this thread? What Version of Gal Civ are you using? If you haven't upgraded, you should try that.

You can get the latest version here:

  http://storage.stardock.com/files/stardockcentral20.exe

If you are using a translated version of Gal Civ, there are often errors made in the data files during translation which can have bad effects.  You can use your serial number to get the full English version from Stardock Central.

Also, please run dxdiag and send the report to me along with your debug.err file.

carielf@stardock.com



        
#22  by Citizen MoseyingAlong - 9/4/2004 8:50:52 PM

I have a divide by zero crasher. I am late in the game, but it crashes every turn...

Report from SmartException follows. Any fixes?

Stardock SmartException Logging Information
-------------------------------------------

OS Version : Windows XP
Video Card : RADEON 9800 XT
Application Exception code: C0000094 INT_DIVIDE_BY_ZERO
Crash Addr: 004E1A82 01:000E0A82 C:\Program Files\Strategy First\Galactic Civilizations\galciv.exe

Processor Registers (x86):
EAX:000048C9
EBX:00000000
ECX:00000000
EDX:00000000
ESI:000001F4
EDI:00000000
CS:EIP:001B:004E1A82
SS:ESP:0023:0FE9FF2C EBP:0FE9FF54
DS:0023 ES:0023 FS:003B GS:0000
Flags:00010246


Current Application Call Stack:

Addr Frame Logical addr Module Name
---------------------------------------------
004E1A82 0FE9FF54 0001:000E0A82 C:\Program Files\Strategy First\Galactic Civilizations\galciv.exe
004E6EF1 0FE9FFA0 0001:000E5EF1 C:\Program Files\Strategy First\Galactic Civilizations\galciv.exe
00519E3F 0FE9FFB4 0001:00118E3F C:\Program Files\Strategy First\Galactic Civilizations\galciv.exe
77E7D33B 0FE9FFEC 0001:0001C33B C:\WINDOWS\system32\kernel32.dll


Debug information for each stardock app follows ....



                          
#23  by Senator CariElf - 9/7/2004 4:29:17 PM

If the last line in your debug.err file is Debug Message:  AIAltarian: Set Colony Social,

then I already fixed it and it'll be in the next update (and I don't know what that's going up yet.)


[Message Edited]

        
#24  by Citizen MoseyingAlong - 9/8/2004 4:53:11 PM

Alas, I gave you my entire debug.err file.

However, I started a new game, and ran to completion. The problem seems to be that an error crept into the save game file at some point, and something pathological happens to the data when some event, such as a UP council meeting, happens.

                          
<<   (1) 2 3 4   ->   >> 
   Page 1 of 4   

Go to Top    Go Back to Message Board    Go to Top
To be able to post something you have to become a member
Click here!



Copyright 1995-2020 Stardock Corporation. All rights reservered.
Site created by Pixtudio and Stardock, designed by Pixtudio.